VoipDiscount

vše o VoipBuster like telefonii
Právě je stř říj 27, 2021 2:08 am

Všechny časy jsou v UTC + 1 hodina [ Letní čas ]




Odeslat nové téma Odpovědět na téma  [ Příspěvek: 1 ] 
Autor Zpráva
 Předmět příspěvku: APACHE2 a PHP5
PříspěvekNapsal: stř lis 07, 2012 10:18 pm 
Offline
Site Admin
Uživatelský avatar

Registrován: stř čer 07, 2006 9:20 pm
Příspěvky: 358
http://forum.pipni.cz/viewtopic.php?f=4&t=12277

[HELP] E: Unable to locate package ...
od DooMxDD » stř říj 17, 2012 5:46 am

Zdravim,
Mam takovy problem ze kdyz napisu jakykoli instalacni prikaz napr.: Kód: Vybrat všeapt-get install apache2 tak mi to napise:
Kód: Vybrat všeapt-get install apache2
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package apache2


Nevite nekdo co s tim prosim ? rekl bych ze je problem a apache ale nepodarilo se mi to vyresit.Nejde absolutne nic nainstalovat.DooMxDD Příspěvky: 4Registrován: stř říj 17, 2012 5:42 am
Nahoru

--------------------------------------------------------------------------------




Re: [HELP] E: Unable to locate package ...

od StraightCore » stř říj 17, 2012 6:07 am

apt-get update

apt-get install apache2



StraightCore Příspěvky: 97Registrován: pát srp 20, 2010 11:30 am
Nahoru

--------------------------------------------------------------------------------




Re: [HELP] E: Unable to locate package ...

od DooMxDD » stř říj 17, 2012 1:58 pm



StraightCore píše:apt-get update

apt-get install apache2



Kód: Vybrat všeapt-get update
Err http://ftp.debian.org squeeze Release.gpg
Temporary failure resolving 'ftp.debian.org'
Err http://ftp.debian.org/debian/ squeeze/contrib Translation-en
Temporary failure resolving 'ftp.debian.org'
Err http://ftp.debian.org/debian/ squeeze/main Translation-en
Temporary failure resolving 'ftp.debian.org'
Err http://ftp.debian.org/debian/ squeeze/non-free Translation-en
Temporary failure resolving 'ftp.debian.org'
Err http://security.debian.org squeeze/updates Release.gpg
Temporary failure resolving 'security.debian.org'
Err http://security.debian.org/ squeeze/updates/contrib Translation-en
Temporary failure resolving 'security.debian.org'
Err http://download.opensuse.org ... Release.gpg
Temporary failure resolving 'download.opensuse.org'
Err http://security.debian.org/ squeeze/updates/main Translation-en
Temporary failure resolving 'security.debian.org'
Err http://security.debian.org/ squeeze/updates/non-free Translation-en
Temporary failure resolving 'security.debian.org'
Reading package lists... Done
W: Failed to fetch http://ftp.debian.org/debian/dists/squeeze/Release.gpg Temporary failure resolving 'ftp.debian.org'

W: Failed to fetch http://ftp.debian.org/debian/dists/sque ... ion-en.bz2 Temporary failure resolving 'ftp.debian.org'

W: Failed to fetch http://ftp.debian.org/debian/dists/sque ... ion-en.bz2 Temporary failure resolving 'ftp.debian.org'

W: Failed to fetch http://ftp.debian.org/debian/dists/sque ... ion-en.bz2 Temporary failure resolving 'ftp.debian.org'

W: Failed to fetch http://security.debian.org/dists/squeez ... elease.gpg Temporary failure resolving 'security.debian.org'

W: Failed to fetch http://security.debian.org/dists/squeez ... ion-en.bz2 Temporary failure resolving 'security.debian.org'

W: Failed to fetch http://security.debian.org/dists/squeez ... ion-en.bz2 Temporary failure resolving 'security.debian.org'

W: Failed to fetch http://security.debian.org/dists/squeez ... ion-en.bz2 Temporary failure resolving 'security.debian.org'

W: Failed to fetch http://download.opensuse.org/repositori ... elease.gpg Temporary failure resolving 'download.opensuse.org'

W: Some index files failed to download, they have been ignored, or old ones used instead.
root@doomxdd:~# apt-get install apache2
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package apache2


nefunguje...DooMxDD Příspěvky: 4Registrován: stř říj 17, 2012 5:42 am
Nahoru

--------------------------------------------------------------------------------




Re: [HELP] E: Unable to locate package ...

od colekx » stř říj 17, 2012 2:02 pm

dopln do /etc/resolv.conf

Kód: Vybrat všesearch vserver.cz
nameserver 78.24.8.150
nameserver 89.235.0.2


A znova spust apt-get update a apt-get install apachecolekx Příspěvky: 13Registrován: stř říj 17, 2012 1:40 pm
Nahoru

--------------------------------------------------------------------------------




Re: [HELP] E: Unable to locate package ...

od DooMxDD » stř říj 17, 2012 2:09 pm



colekx píše:dopln do /etc/resolv.conf

Kód: Vybrat všesearch vserver.cz
nameserver 78.24.8.150
nameserver 89.235.0.2


A znova spust apt-get update a apt-get install apache


Kód: Vybrat všeapt-get update
Hit http://security.debian.org squeeze/updates Release.gpg
Ign http://security.debian.org/ squeeze/updates/contrib Translation-en
Ign http://security.debian.org/ squeeze/updates/main Translation-en
Ign http://security.debian.org/ squeeze/updates/non-free Translation-en
Hit http://security.debian.org squeeze/updates Release
Hit http://ftp.debian.org squeeze Release.gpg
Ign http://ftp.debian.org/debian/ squeeze/contrib Translation-en
Ign http://ftp.debian.org/debian/ squeeze/main Translation-en
Ign http://ftp.debian.org/debian/ squeeze/non-free Translation-en
Hit http://security.debian.org squeeze/updates/main i386 Packages
Hit http://ftp.debian.org squeeze Release
Hit http://security.debian.org squeeze/updates/contrib i386 Packages
Hit http://security.debian.org squeeze/updates/non-free i386 Packages
Hit http://ftp.debian.org squeeze/main i386 Packages
Hit http://ftp.debian.org squeeze/contrib i386 Packages
Hit http://ftp.debian.org squeeze/non-free i386 Packages
Ign http://download.opensuse.org ... Release.gpg
Ign http://download.opensuse.org ... Release
Ign http://download.opensuse.org .../ebian_6.0/ Sources
Ign http://download.opensuse.org ...// Sources
Ign http://download.opensuse.org .../ebian_6.0/ Sources
Ign http://download.opensuse.org ...// Sources
Err http://download.opensuse.org .../ebian_6.0/ Sources
404 Not Found
Err http://download.opensuse.org ...// Sources
404 Not Found
W: Failed to fetch http://download.opensuse.org/repositori ... Sources.gz 404 Not Found

W: Failed to fetch http://download.opensuse.org/repositori ... Sources.gz 404 Not Found

E: Some index files failed to download, they have been ignored, or old ones used instead.
root@doomxdd:~# apt-get install apache2
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
apache2-mpm-worker
The following NEW packages will be installed:
apache2 apache2-mpm-worker
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 3622 B of archives.
After this operation, 106 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ftp.debian.org/debian/ squeeze/main apache2-mpm-worker i386 2.2.16-6+squeeze8 [2230 B]
Get:2 http://ftp.debian.org/debian/ squeeze/main apache2 i386 2.2.16-6+squeeze8 [1392 B]
Fetched 3622 B in 0s (62.8 kB/s)
Selecting previously deselected package apache2-mpm-worker.
(Reading database ... 22979 files and directories currently installed.)
Unpacking apache2-mpm-worker (from .../apache2-mpm-worker_2.2.16-6+squeeze8_i386.deb) ...
Selecting previously deselected package apache2.
Unpacking apache2 (from .../apache2_2.2.16-6+squeeze8_i386.deb) ...
Setting up apache2-mpm-worker (2.2.16-6+squeeze8) ...
Starting web server: apache2WARNING: MaxClients (10) must be at least as large
as ThreadsPerChild (25). Automatically
increasing MaxClients to 25.
.
Setting up apache2 (2.2.16-6+squeeze8) ...

apt-get update nefunguje a apache se nainstalovat podarilo.Ale stejne porad kdyz chci otevrit nejaky .php soubor tak mi ho to zacne stahovat misto toho aby ho to otevrelo.DooMxDD Příspěvky: 4Registrován: stř říj 17, 2012 5:42 am
Nahoru

--------------------------------------------------------------------------------




Re: [HELP] E: Unable to locate package ...

od colekx » stř říj 17, 2012 2:13 pm

ten vypis od apt-get je v poradku..
Naistaloval jste PHP?

Kód: Vybrat všeapt-get install php5 php5-mysql libapache2-mod-php5

pak zkuste ve /var/www/ vytvorit soubor test.php a do nej vepiste

Kód: Vybrat vše<?php phpinfo(); ?>

a prejdete na adresu serveru 1.2.3.4/test.php melo by se zobrazit info..

Pripadne probehl restart serveru?colekx Příspěvky: 13Registrován: stř říj 17, 2012 1:40 pm
Nahoru

--------------------------------------------------------------------------------




Re: [HELP] E: Unable to locate package ...

od DooMxDD » stř říj 17, 2012 2:23 pm

Funguje Dekuji mnohokrat ^^
DooMxDD Příspěvky: 4Registrován: stř říj 17, 2012 5:42 am
Nahoru

--------------------------------------------------------------------------------




Re: [HELP] E: Unable to locate package ...

od colekx » stř říj 17, 2012 2:30 pm

neni zac..


Nahoru
 Profil  
 
Zobrazit příspěvky za předchozí:  Seřadit podle  
Odeslat nové téma Odpovědět na téma  [ Příspěvek: 1 ] 

Všechny časy jsou v UTC + 1 hodina [ Letní čas ]


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 1 návštěvník


Nemůžete zakládat nová témata v tomto fóru
Nemůžete odpovídat v tomto fóru
Nemůžete upravovat své příspěvky v tomto fóru
Nemůžete mazat své příspěvky v tomto fóru
Nemůžete přikládat soubory v tomto fóru

Hledat:
Přejít na:  
cron
Založeno na phpBB® Forum Software © phpBB Group
Český překlad – phpBB.cz